All Collections
Creating & Editing Mixes
Studio View (Editing, Arranging, Controls)
Studio View (Editing, Arranging, Controls)

The Studio Window is the main interface for editing and perfecting your mix.

Noah Feasey-Kemp avatar
Written by Noah Feasey-Kemp
Updated over a week ago

Here, you have access to all the tools you need to refine your mix, make transitions, and perform other important actions.

There are several sub-sections and tabs within the Studio view. Each will be explained in detail below.


Navigation Bar

The navigation bar is at the top of the timeline editor, and makes it easy to get an overview of your project, and move around the timeline.

This enables a range of actions and shows you some important information.

  1. Playhead Mode = This toggle enables the timeline to automatically scroll with the playhead as your project plays, or for the screen to stay still.

  2. Scroll bar & Overview = This handy bar displays the arrangement of your mixes, and can be used for quick and easy navigation.

    1. Click anywhere in the navigation bar to jump to that section of the arrangement

    2. Drag the bar from side to side to scroll through your project.

    3. Drag the bar up/down to zoom out/in.

  3. Quick Zoom Buttons = These let you switch between 5 levels of zoom, from 1 (far zoom out) to 5 (Zoom in to beat level).

  4. Time Ruler = This displays the measurement of time for your arrangement. You can switch between Bars or Minutes by clicking the ruler.


Track Mixer Controls

This section gives you control over each track, just like how a DJ mixer works.

You can record automation for these parameters too, by using the Automation Record function.

  1. Filter = This is a hybrid Low-Cut/High-Cut filter control.

    1. Turning the control left filters out the highs until only the bass is left.

    2. Turning right does the opposite, cutting out the bass and leaving the highs.

    3. Placing the control to the center leaves the sound unaffected.

    4. You can reset the filter by double-clicking the knob.

  2. 3-Band EQ = Just like most decks, this gives you control over the High, Mid, and Low frequencies of each track.

    1. Turn knobs right to boost the band.

    2. Turn knobs left to reduce the band.

    3. Double-click to reset.

  3. Solo = Solos the track, muting the other one.


Timeline Editor

The Timeline editor is the main interface for fine-tuning your mixes. It provides several interactions and controls.

View Navigation

You can use the Timeline interface to move the viewpoint around.

  • Click and drag an empty area of the timeline to move the view left or right.

  • Use the mouse scroll wheel to zoom in/out.

  • Single-click in an area on the timeline to move the playhead to the selected location.


Moving and Editing Audio

The Timeline editor can be used to adjust various elements of your arrangement.

Note, that this section is not the place to change the order of your tracks. You can reorder tracks in the Playlist tab

You can use the Timeline Editor to:

  • Click and drag the yellow top handle of a track to move it left or right in the arrangement.

  • Click and drag over the waveform to highlight sections of a track. You can then

    • Press ‘Delete’ to remove the highlighted section.

    • Press Ctrl+C to copy the section.

    • Press Ctrl+V to paste the copied section. This will be pasted at the playhead marker, so you can paste it wherever you need to.

  • Adjust transitions between tracks - See the main chapter for the full details on this > Transition Editor


Beat Marker Replacement

When you zoom in, you can see the beat grid. This displays how DJ.Studio analyzed the beats.

You will see yellow beat markers indicating the detection points for the beat, and a white, blue, and green waveform display representing the audio.

Sometimes, the placement is off, which means tracks won’t be beat-matched correctly.

We implemented a system that lets you move the beat markers in time with the audio, so you can easily fix a misalignment issue.

This video shows you the process - How To Fix Beatmatching Issues: Nudging The Beatgrid

Or follow these instructions:

  1. Zoom in to a level where you can see the yellow beat marker lines.

  2. Listen to the track, while looking at the waveform and work out where bars and beats are. Typically it will be a large blue bump in the waveform.

  3. Drag a yellow marker to the start of a beat on the waveform. You need to hold Shift+Click to move the marker

  4. DJ.Studio will anchor the beat grid to the chosen point in the waveform.

  5. The beat marker will get white triangles on top and bottom to indicate that it is an anchor.

  6. You can place multiple beat anchors as long as they are more than 16 beats apart.

  7. The beats in between the beat anchors will be arranged according to the bpm of the track.

After you have dragged the beat markers to the right spot, DJ.Studio will automatically realign both tracks so that the tracks are beat-matched.

After that, you can start to edit the transitions, by moving the placement of the tracks.

Alternatively:

  1. Open the Studio View

  2. Zoom in to your track until you see the white waveforms and the yellow beatmarkers

  3. On the right side of the screen in each track you see 6 buttons which you can use to nudge the track so it does match with the beatmarkers.

  4. Nudge the track to the left or the right to align the yellow beatmarker with the waveform and you are all set!


BPM Bar

The BPM bar displays the beats per minute for each track in the arrangement.

The automation line also gives you control over the BPM, and can be drawn in freely.

Simply click the line to create a new point, and move it left/right in time or up/down in BPM.

Track speeds will transition smoothly between automated BPM points.

Right-Click BPM Options

You can right-click the BPM bar to access four extra options.

  1. Set track BPM - Type in a new BPM for the chosen track.

  2. Add BPM Point - Create a new automation point for changing the BPM.

  3. Set Mix BPM = This opens a new window, letting you set the Mix BPM from a wider perspective. You can set the Start and End BPM. You can use this to create a consistent ramp either up or down in speed, or you can set both values the same, to create a constant BPM for the whole mix.

  4. Restore All Tracks to Original BPM = As the name suggests, this resets all BPM automation so that every track plays at the original BPM


Center Bar and Playback Buttons

The Center Bar gives you a range of controls and buttons relating to playback and other functions.

Note - Some of the buttons displayed here will change depending on which tab you have open.

Most of these actions can be triggered with a keyboard shortcut, as listed below.

(Note - for Windows, replace CMD with CTRL)

The main buttons are:

  • Add Tracks - Open the track import and library window.

  • Automix - Open the Automix dialog

  • Undo - reverts the last action you made = cmd + z

  • Redo - Recreates the last action reverted by undo = cmd + y

  • Edit - Opens a dropdown with buttons for the following operations

    • Cut - the selected area = cmd + x

    • Copy - the selected area = cmd + c

    • Paste - the copied or cut audio to the selected location = cmd + v

    • Delete Menu- A range of options for deleting different components, such as audio, automation, and edits.

  • Jump Back - Moves the playhead back by a short amount

  • Jump Forward - Moves the playhead forward by a short amount

  • Record - Enables automation recording (see the full chapter)

  • Play/Pause - Enables or disables playback of the mix

  • Replay Transition - Jumps the playhead back to the start of the previous transition.

  • Previous Transition - Jumps the playhead back to the last transition.

  • Next Transition - Skips the playhead to the next transition.

  • Solo - Switches the solo mode through the two tracks.

  • Metronome - Toggles a metronome playing at the current BPM, on beat with the grid

  • Shortcuts - Opens the keyboard shortcut

  • Zoom In/Out - Changes the view zoom of the timeline editor


Studio View Tabs

The tab selector at the bottom of the Studio View screen lets you navigate through the various sub-windows.

Each of these gives access to a range of different tools and options, which are explained below.


Zoom Mode

The zoomed mode displays the timeline across the entire screen. This creates a larger view of the waveform, and makes it easier to create detailed automation and edits.


Playlist View

The playlist view lets you view your mix in a dual view: studio + playlist. The scrollable playlist at the bottom of the screen allows you to see all the details of your tracks and change the order or delete tracks.

The top of the screen displays the studio view, with all transitions, automation and BPM.


Transition Tab

The Transition tab provides controls for quickly creating transitions.


Track Tab

The track tab shows you information about the currently selected track.

It also lets you perform a few modification options.

Beat Mode

This option lets you control how the DJ.Studio engine processes audio files when changing their BPM and key. Each algorithm type works in a different way, and changes the sound in a unique way based on how the process is performed.

  • Vinyl - Mimics the effect of vinyl - a track’s pitch is increased when the BPM is increased, and the pitch is lowered when the BPM is decreased.

  • Re-pitch - This uses a repitching algorithm to counteract the effects of the pitch being altered by a shifted BPM

On the left side of the Track tab you see that we now have a few Beat grid options.

Beat grid

  • Manual is selected when you have made changes to your beat grid manually

  • Fixed is the improved version of our current beat grid algorithm.

    Perfect for EDM or music with few changes in tempo. We improved the general beat detection and the detection of the first beat specifically.

  • Variable is useful when you have tracks with timing and tempo changes, like old disco songs. We look for the beats in the music and adjust the gird accordingly.

  • AI: The generation of the AI beat grid is based on stems, so this will only be visible if you have access to the stems .

Track Information Editor

This section displays information about the track and also lets you change the info.

Use this window to make your library easier to navigate, by adding genres to tracks, giving them a star rating, updating the Title and Artist name, or adding notes.

It also shows information, including

  • The album art

  • The track length in Minutes:Seconds

  • The track’s key

  • The date the track was imported

  • The file type and file size

  • How many times you use the track in a project.


Video Tab

The Video tab is used for creating custom videos for your mix, or watching attached YouTube videos.


Effects Tab

Influence the sound of your tracks with the Effects tab.

  1. Set the gain and compression per track. Gain adjustment is about controlling the overall volume levels of individual tracks, while compression is about controlling the dynamic range within each track to achieve a more balanced and polished sound in the mix.

  2. Use the EQ Three to adjust the levels of three different frequency bands: low, mid, and high.

  3. The FX slider lets you set the filter for the track. Combined with echo, reverb, and flanger, you can create a specific tone or mood for your track.

  4. Echo: Repeats the sound with a delay, like an audio reflection. It can create a sense of space or depth in the music.

  5. Reverb (Reverberation): Reverb is similar to echo but more diffuse. It simulates the reflections of sound bouncing off surfaces in a room. It makes the sound feel like it's in a physical space, adding ambiance and depth.

  6. Flanger: Creates a swirling, swooshing effect by mixing a slightly delayed copy of the sound with the original signal. It's often used to add movement and texture to instruments or vocals.

  7. White noise is a versatile tool in music mixing that can be used creatively to enhance the sound and achieve desired sonic characteristics.

  8. Use the pitch slider to correct off-key vocals or create harmonies.


Master Tab

In this tab, you can set your limiter (max volume) and compressor (smooth out volume). This is especially useful when you use samples or tracks that vary in volume.

The compressor can also be found on the ‘effects’ tab.

Compressor

Think of a compressor as a volume manager. It makes loud sounds quieter and brings up quieter sounds, making everything more even and balanced. The compressor can be set per track.

Limiter

A limiter is like a bodyguard for your audio. Setting a maximum volume level stops the sound from getting too loud and causing damage or distortion. The limiter setting affects the whole mix.


Samples Tab

The Samples tab shows your complete sample library sorted into tabs.

If you want to know more about using samples in your mix, check out our article about Samples.

Did this answer your question?